re = /(<dependency>)((?!<dependency>)\s*?\S*?\w*?\W*?.*?\X*?\R*?\v*?)(spring-core)(\s*?\S*?\w*?\W*?.*?\X*?\R*?\v*?(?<!<dependency>))(<\/dependency>)/
str = '<dependency>
<groupId>org.springframework</groupId>
<artifactId>spring-jdbc</artifactId>
<version>${spring.version}</version>
</dependency>
<dependency>
<groupId>org.springframework</groupId>
<artifactId>spring-core</artifactId>
<version>${spring.version}</version>
<exclusions>
<exclusion>
<groupId>commons-logging</groupId>
<artifactId>commons-logging</artifactId>
</exclusion>
</exclusions>
</dependency>'
# Print the match result
str.match(re) do |match|
puts match.to_s
end