package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\w+)\s+=\s+\w+(?:,|$)`)
var str = `abc = a1, def = b2, ghi = c3`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}