$re = '/(\w+)\s+=\s+\w+(?:,|$)/m';
$str = 'abc = a1, def = b2, ghi = c3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);