$re = '/(en-gb|en-us|da)(?!\1)(en-gb|en-us|da)/';
$str = 'en-usen-usen-gben-us
enenen-usen-gb';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);