re = /(en-gb|en-us|da)(?!\1)(en-gb|en-us|da)/
str = 'en-usen-usen-gben-us
enenen-usen-gb'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end