using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\|(?=(?:[^""]*""[^""]*"")*[^""]*$)";
string input = @"this is|""text | quoted""|""this ""is double"" | quoted""|some text|this is|""text | quoted""|""this ""is double"" | quoted""|some text";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}