$re = '/\|(?=(?:[^"]*"[^"]*")*[^"]*$)/';
$str = 'this is|"text | quoted"|"this ""is double"" | quoted"|some text|this is|"text | quoted"|"this ""is double"" | quoted"|some text';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);