import re
regex = re.compile(r"(?=(\b\w{4,}\b)(?:.*\b\1\b){2})(?!(\b\w{4,}\b)(?:.*\b\1\b){3})", flags=re.IGNORECASE)
test_str = ("hello how are you today hello hello hello\n")
subst = "*"
result = regex.sub(subst, test_str)
if result:
print(result)