const regex = /\b(?>\([\w\/]+\)|[\w\/])+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(?>\\([\\w\\\/]+\\)|[\\w\\\/])+', 'g')
const str = `I am a robot, I have been named 456/m(4) 456/m(4). Forget the name (it does not mean anything) exposed to 360J/m(2) and 456/m(4)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}