re = /\b(?>\([\w\/]+\)|[\w\/])+/
str = 'I am a robot, I have been named 456/m(4) 456/m(4). Forget the name (it does not mean anything) exposed to 360J/m(2) and 456/m(4)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end