const regex = /(?x)(?:^|\s|\G)(\*\*|__)(?=\S)(?=(<[^>]*+>| (?<raw>`+)([^`]|(?!(?<!`)\k<raw>(?!`))`)*+\k<raw>|\\[\\`*_{}\[\]()#.!+\->]?+| \[((?<square>[^\[\]\\]| \\.| \[ \g<square>*+ \])*+\](([ ]?\[[^\]]*+\])| (\([ \t]*+<?(.*?)>?[ \t]*+((?<title>['"])(.*?)\k<title>)?\))))|(?!(?<=\S)\1).)++(?<=\S)\1)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?x)(?:^|\\s|\\G)(\\*\\*|__)(?=\\S)(?=(<[^>]*+>| (?<raw>`+)([^`]|(?!(?<!`)\\k<raw>(?!`))`)*+\\k<raw>|\\\\[\\\\`*_{}\\[\\]()#.!+\\->]?+| \\[((?<square>[^\\[\\]\\\\]| \\\\.| \\[ \\g<square>*+ \\])*+\\](([ ]?\\[[^\\]]*+\\])| (\\([ \\t]*+<?(.*?)>?[ \\t]*+((?<title>[\'"])(.*?)\\k<title>)?\\))))|(?!(?<=\\S)\\1).)++(?<=\\S)\\1)', '')
const str = `I like bold (**like this**) but it isn't!`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}