$re = '/(?x)(?:^|\s|\G)(\*\*|__)(?=\S)(?=(<[^>]*+>| (?<raw>`+)([^`]|(?!(?<!`)\k<raw>(?!`))`)*+\k<raw>|\\\\[\\\\`*_{}\[\]()#.!+\->]?+| \[((?<square>[^\[\]\\\\]| \\\\.| \[ \g<square>*+ \])*+\](([ ]?\[[^\]]*+\])| (\([ \t]*+<?(.*?)>?[ \t]*+((?<title>[\'"])(.*?)\k<title>)?\))))|(?!(?<=\S)\1).)++(?<=\S)\1)/';
$str = 'I like bold (**like this**) but it isn\'t!';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);