using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:E\d)([\w\d_]+)(?:_LLC)";
string input = @"0x010102_default_prg_L2_E2_LDep1_LLC
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}