$re = '/^([A-Z])[^\sA-Z]*([A-Z])[^\sA-Z]*([A-Z])/m';
$str = 'XYZName
X.YZName
XY-ZName';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);