re = /^([A-Z])[^\sA-Z]*([A-Z])[^\sA-Z]*([A-Z])/m
str = 'XYZName
X.YZName
XY-ZName'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end