#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[\p{Pd}\xAD\x{2212}]+"
Local $sString = "-s < intorstring >" & @CRLF & _
"-t < string >" & @CRLF & _
"(GTF.featureType)" & @CRLF & _
"Specify the feature type. Only rows which have the matched" & @CRLF & _
"feature type in the provided GTF annotation file will be included for read counting. ‘exon’ by default." & @CRLF & _
"-T < int >" & @CRLF & _
"(nthreads)" & @CRLF & _
"Number of the threads. The value should be between 1 and" & @CRLF & _
"32. 1 by default." & @CRLF & _
"-v Output version of the program." & @CRLF & _
"−−byReadGroup" & @CRLF & _
"(byReadGroup)" & @CRLF & _
"Count reads by read group. Read group information is identified from the header of BAM/SAM input files and the generated count table will include counts for each group in each" & @CRLF & _
"library." & @CRLF & _
"−−donotsort" & @CRLF & _
"(autosort)" & @CRLF & _
"If specified, paired end reads will not be re-ordered even if" & @CRLF & _
"reads from the same pair were found not to be next to each" & @CRLF & _
"other in the input." & @CRLF & _
"−−extraAttributes" & @CRLF & _
"< string >" & @CRLF & _
"(GTF.attrType.extra)" & @CRLF & _
"Extract extra attribute types from the provided GTF annotation and include them in the counting output. These attribute" & @CRLF & _
"types will not be used to group features. If more than one attribute type is provided they should be separated by comma" & @CRLF & _
"(in Rsubread featureCounts its value is a character vector)." & @CRLF & _
"−−fraction" & @CRLF & _
"(fraction)" & @CRLF & _
"Assign fractional counts to features. This option must be used" & @CRLF & _
"together with ‘-M’ or ‘-O’ or both. When ‘-M’ is specified," & @CRLF & _
"each reported alignment from a multi-mapping read (identified via ‘NH’ tag) will carry a count of 1/x, instead of 1 (one)," & @CRLF & _
"where x is the total number of alignments reported for the" & @CRLF & _
"same read. When ‘-O’ is specified, each overlapping feature" & @CRLF & _
"will receive a count of 1/y, where y is the total number of" & @CRLF & _
"features overlapping with the read. When both ‘-M’ and ‘-O’" & @CRLF & _
"are specified, each alignment will carry a count of 1/(x*y)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")