const regex = /^[\p{Pd}\xAD\x{2212}]+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[\\p{Pd}\\xAD\\x{2212}]+', 'gm')
const str = `-s < intorstring >
-t < string >
(GTF.featureType)
Specify the feature type. Only rows which have the matched
feature type in the provided GTF annotation file will be included for read counting. ‘exon’ by default.
-T < int >
(nthreads)
Number of the threads. The value should be between 1 and
32. 1 by default.
-v Output version of the program.
−−byReadGroup
(byReadGroup)
Count reads by read group. Read group information is identified from the header of BAM/SAM input files and the generated count table will include counts for each group in each
library.
−−donotsort
(autosort)
If specified, paired end reads will not be re-ordered even if
reads from the same pair were found not to be next to each
other in the input.
−−extraAttributes
< string >
(GTF.attrType.extra)
Extract extra attribute types from the provided GTF annotation and include them in the counting output. These attribute
types will not be used to group features. If more than one attribute type is provided they should be separated by comma
(in Rsubread featureCounts its value is a character vector).
−−fraction
(fraction)
Assign fractional counts to features. This option must be used
together with ‘-M’ or ‘-O’ or both. When ‘-M’ is specified,
each reported alignment from a multi-mapping read (identified via ‘NH’ tag) will carry a count of 1/x, instead of 1 (one),
where x is the total number of alignments reported for the
same read. When ‘-O’ is specified, each overlapping feature
will receive a count of 1/y, where y is the total number of
features overlapping with the read. When both ‘-M’ and ‘-O’
are specified, each alignment will carry a count of 1/(x*y)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}