$re = '/^\p{Lu}\p{Ll}+( \p{Lu}\p{Ll}+)*$/m';
$str = 'Merianos Nikos
Μέριανος Νίκοςfg
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);