re = /^\p{Lu}\p{Ll}+( \p{Lu}\p{Ll}+)*$/m
str = 'Merianos Nikos
Μέριανος Νίκοςfg
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end