$re = '`\b(?:Encouter Date \d{2}/\d{2}/\d{4} )?(?:BP:?(?:-Sitting)?|Blood Pressure) \d+(?:/\d+){0,2}(?: ?\d+(?:/\d+){0,2})*(?: sm| -Lw| cB| Jr|\
-aA| cs| -ic| ic| -RG| kA| -sL| BL| kc| am| -sH| sH| es| ts| np| 8s| ca| Pm| JE| so| cp| v8| Eu| -cp|\
Pm| EB| Fr| -Fr| -ms| -LN| -mT| -mk| -GF| -HO| Jp| wD| 8m| mc| -mc| Yr| -Lp| -ml| -LA| s/d| -aA| s/d|mmHg| mm Hg|\
mm hg.)?|B/P - (?:Sys|Dias)tolic \d+|(?:Sys|Dias)tolic Blood Pressure \d+ \w+\b`m';
$str = 'Bodu Mass Index 21.5 07/27/18 Blood Pressure 134/78 07/27/18 Position Sitting BP 10/30/17 1345 178/80
Amett Hayley MR# 70583797 DOB 07/14/1962 Encouter Date 02/21/2018 BP 136/88 Site Left Arm Cuff Size Large';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);