// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\b(?:Encouter Date \d{2}/\d{2}/\d{4} )?(?:BP:?(?:-Sitting)?|Blood Pressure) \d+(?:/\d+){0,2}(?: ?\d+(?:/\d+){0,2})*(?: sm| -Lw| cB| Jr|\
-aA| cs| -ic| ic| -RG| kA| -sL| BL| kc| am| -sH| sH| es| ts| np| 8s| ca| Pm| JE| so| cp| v8| Eu| -cp|\
Pm| EB| Fr| -Fr| -ms| -LN| -mT| -mk| -GF| -HO| Jp| wD| 8m| mc| -mc| Yr| -Lp| -ml| -LA| s/d| -aA| s/d|mmHg| mm Hg|\
mm hg.)?|B/P - (?:Sys|Dias)tolic \d+|(?:Sys|Dias)tolic Blood Pressure \d+ \w+\b").unwrap();
let string = "Bodu Mass Index 21.5 07/27/18 Blood Pressure 134/78 07/27/18 Position Sitting BP 10/30/17 1345 178/80
Amett Hayley MR# 70583797 DOB 07/14/1962 Encouter Date 02/21/2018 BP 136/88 Site Left Arm Cuff Size Large";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}