using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([.\$\""\/\\\:|]+)";
string input = @"sa.df$dfd""fd\ /dfdfd|
";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}