package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)([.\$\"\/\\\:|]+)`)
var str = `sa.df$dfd"fd\ /dfdfd|
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}