#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\b(?:[0-9]{1,3}\.){3}[0-9]{1,3}\b"
Local $sString = "Return-path: <Walk-in.Whirlpool.Tubs@familywhitetubin.date>" & @CRLF & _
"Envelope-to: jblumberg@menshealthandwellness.org" & @CRLF & _
"Delivery-date: Mon, 31 Aug 2015 15:38:19 -0400" & @CRLF & _
"Received: from [50.2.8.182] (port=34151 helo=familywhitetubin.date)" & @CRLF & _
" by host.menshealthandwellness.org with esmtp (Exim 4.85)" & @CRLF & _
" (envelope-from <Walk-in.Whirlpool.Tubs@familywhitetubin.date>)" & @CRLF & _
" id 1ZWUuJ-0003hH-6L" & @CRLF & _
" for jblumberg@menshealthandwellness.org; Mon, 31 Aug 2015 15:38:19 -0400" & @CRLF & _
"Date: Mon, 31 Aug 2015 12:47:39 -0700" & @CRLF & _
"Message-ID: <77f581ddf9662409a9e27aaac2f26d74.14325456.20579279@familywhitetubin.date>" & @CRLF & _
"From: Walk-in.Whirlpool.Tubs <Walk-in.Whirlpool.Tubs@familywhitetubin.date>" & @CRLF & _
"To: <jblumberg@menshealthandwellness.org>" & @CRLF & _
"Dvhgo-Wu: 14325456i.20579279nr.o20579279" & @CRLF & _
"Content-Type: text/plain" & @CRLF & _
"Mime-Version: 1.0" & @CRLF & _
"Subject: Enjoy Safe, Comfortable Bathing in your Jacuzzi Walk-In-Bath, Quote: 14325456" & @CRLF & _
"Mi-Tdx: 77f581ddf9662409a9e27aaac2f26d74t-20579279br.d14325456" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")