import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?:[0-9]{1,3}\\.){3}[0-9]{1,3}\\b";
final String string = "Return-path: <Walk-in.Whirlpool.Tubs@familywhitetubin.date>\n"
+ "Envelope-to: jblumberg@menshealthandwellness.org\n"
+ "Delivery-date: Mon, 31 Aug 2015 15:38:19 -0400\n"
+ "Received: from [50.2.8.182] (port=34151 helo=familywhitetubin.date)\n"
+ " by host.menshealthandwellness.org with esmtp (Exim 4.85)\n"
+ " (envelope-from <Walk-in.Whirlpool.Tubs@familywhitetubin.date>)\n"
+ " id 1ZWUuJ-0003hH-6L\n"
+ " for jblumberg@menshealthandwellness.org; Mon, 31 Aug 2015 15:38:19 -0400\n"
+ "Date: Mon, 31 Aug 2015 12:47:39 -0700\n"
+ "Message-ID: <77f581ddf9662409a9e27aaac2f26d74.14325456.20579279@familywhitetubin.date>\n"
+ "From: Walk-in.Whirlpool.Tubs <Walk-in.Whirlpool.Tubs@familywhitetubin.date>\n"
+ "To: <jblumberg@menshealthandwellness.org>\n"
+ "Dvhgo-Wu: 14325456i.20579279nr.o20579279\n"
+ "Content-Type: text/plain\n"
+ "Mime-Version: 1.0\n"
+ "Subject: Enjoy Safe, Comfortable Bathing in your Jacuzzi Walk-In-Bath, Quote: 14325456\n"
+ "Mi-Tdx: 77f581ddf9662409a9e27aaac2f26d74t-20579279br.d14325456\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}