using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(fleece)(?!.*?snow)";
string input = @"Mary had a little lamb, its fleece was white as snow balls
Mary had a little lamb, its fleece.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}