$re = '/(fleece)(?!.*?snow)/m';
$str = 'Mary had a little lamb, its fleece was white as snow balls
Mary had a little lamb, its fleece.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);