import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\+?(?![^ \\n-]*[ -]{2})(?=(?:[ -]*\\d){10,12}$)\\d[\\d -]*\\d$";
final String string = "+12 1234567890\n"
+ "+12 12 345 567 89\n"
+ "+12 123-455-6789\n"
+ "+9712345567\n\n"
+ "Additional good\n"
+ "9712345567\n\n"
+ "Additional bad\n"
+ "+9712345- - 567\n"
+ "+9712345678 \n"
+ " +9712345678\n"
+ "+ 9712345678\n"
+ "+97--12345678\n\n"
+ "+1234567890123\n"
+ "+123456789\n\n"
+ "The regex is for validating phone numbers so it should have minimum length 10 digits and maximum length of 12 digits except special symbols like +, - and space.\n"
+ "Plus sign only allowed at start. I tried below regex but not working for me.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}