use strict;
my $str = '+12 1234567890
+12 12 345 567 89
+12 123-455-6789
+9712345567
Additional good
9712345567
Additional bad
+9712345- - 567
+9712345678
+9712345678
+ 9712345678
+97--12345678
+1234567890123
+123456789
The regex is for validating phone numbers so it should have minimum length 10 digits and maximum length of 12 digits except special symbols like +, - and space.
Plus sign only allowed at start. I tried below regex but not working for me.';
my $regex = qr/^\+?(?![^ \n-]*[ -]{2})(?=(?:[ -]*\d){10,12}$)\d[\d -]*\d$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}