using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"H\.?S[.\s-]CODE[:\s]+\K[\d.]+";
string input = @"============H.S.CODE: 8466.93
RECONDHS CODE 84669400AMS REF CHS220928SCAC SSLL
1 AUTOMATION BYTRANSEXTENDED 4020.HS-CODE: 8428.9000";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}