$re = '/H\.?S[.\s-]CODE[:\s]+\K[\d.]+/';
$str = '============H.S.CODE: 8466.93
RECONDHS CODE 84669400AMS REF CHS220928SCAC SSLL
1 AUTOMATION BYTRANSEXTENDED 4020.HS-CODE: 8428.9000';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);