use strict;
my $str = 'Dear Cdr. Sonia S S,';
my $regex = qr/(?<= )\p{L}+(?= )/mp;
my $subst = '****';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";