$re = '/(?<= )\p{L}+(?= )/m';
$str = 'Dear Cdr. Sonia S S,';
$subst = "****";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;