package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\d+)\s*(.*)`)
var str = `7 year
2day
4 week
8 month`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}