$re = '/(\d+)\s*(.*)/';
$str = '7 year
2day
4 week
8 month';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);