package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\[\S+ ((?:[^"]+"){2}) ((?:[^"]+"){2})\]`)
var str = `[person name="Jackson" family="Smith"]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}