re = /\[\S+ ((?:[^"]+"){2}) ((?:[^"]+"){2})\]/m
str = '[person name="Jackson" family="Smith"]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end