package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\.?0+$`)
var str = `1.7500
1.1010
1.0000`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}