#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?i)(?=.*\bLorem\b).*(?=.*\btext\b).*(?=.*\bdummy\b).*"
Local $sString = "Ipsum is simply dummy text of the printing and typesetting industry. " & @CRLF & _
"" & @CRLF & _
"Lorem Ipsum has been the industry's standard dummy text ever since the"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")