using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^category/(?:(\w+)/){1,3}offre/(\d+)";
string input = @"category/sorganiser/bouger/escalade/offre/78934/
category/sorganiser/savourer/offre/8040/";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}