re = /^category\/(?:(\w+)\/){1,3}offre\/(\d+)/m
str = 'category/sorganiser/bouger/escalade/offre/78934/
category/sorganiser/savourer/offre/8040/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end