$re = '/(?<=@wiki\s).*$/isu';
$str = 'hello @theAbbie, this is how @C0D4 finds all the text after the bots name, like @wiki hotdogs
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);