package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(https?\:)\/\/(([^:\/?#]*)(?:\:([0-9]+))?)([\/]{0,1}[^?#]*)(\?[^#]*|)(#.*|)$`)
var str = `https://www.something.com:80/example/urlTest/?good=job&some=pharam&page=55#Hash_Tag`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}