re = /^(https?\:)\/\/(([^:\/?#]*)(?:\:([0-9]+))?)([\/]{0,1}[^?#]*)(\?[^#]*|)(#.*|)$/
str = 'https://www.something.com:80/example/urlTest/?good=job&some=pharam&page=55#Hash_Tag'
# Print the match result
str.match(re) do |match|
puts match.to_s
end