package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`:(?:<[^>]*>|[^:])*somemoney`)
var str = `:</w:t></w:r>xxxxxxxuyyyyyzzzzz:</w:t></w:r>xxxxuuuxxxyyyyyzzzzzsomemoney`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}