re = /:(?:<[^>]*>|[^:])*somemoney/
str = ':</w:t></w:r>xxxxxxxuyyyyyzzzzz:</w:t></w:r>xxxxuuuxxxyyyyyzzzzzsomemoney'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end