#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)\[\/?COLOR[^]]*[\]]?"
Local $sString = "[color=#FF0000].[/color] content content content content content content [color=#FF0000]content [/color]content content[color=#FF0000], [/color]content content. content content content content [color=#FF0000],[/color] content content content. content [color=#FF0000]content[/color] content content content [color=#FF0000],[/color][color=#FF0000]content[/color] content [color=#FF0000],[/color][color=#FF0000]content content content content content[/color], content content content content content content content content. content content[color=#FF0000]-[/color] content content content content [color=#FF0000]content[/color] content ? content content content content content content content content content content content content content [color=#FF0000]-[/color]content 1 июня[color=#FF0000], [/color]например или нет как начало отпуска? [color=#FF0000]content content content content content.Расставляйте запятые,чтобы предложение не было сплошным набором слов. content content content content -content или вашего друга?А то по вашей манере написания это непонятно.content.[/color[color=#FF0000][color=#FF0000][color=#FFFF80][/color]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")