import Foundation
let pattern = #"\[\/?COLOR[^]]*[\]]?"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = ##"[color=#FF0000].[/color] content content content content content content [color=#FF0000]content [/color]content content[color=#FF0000], [/color]content content. content content content content [color=#FF0000],[/color] content content content. content [color=#FF0000]content[/color] content content content [color=#FF0000],[/color][color=#FF0000]content[/color] content [color=#FF0000],[/color][color=#FF0000]content content content content content[/color], content content content content content content content content. content content[color=#FF0000]-[/color] content content content content [color=#FF0000]content[/color] content ? content content content content content content content content content content content content content [color=#FF0000]-[/color]content 1 июня[color=#FF0000], [/color]например или нет как начало отпуска? [color=#FF0000]content content content content content.Расставляйте запятые,чтобы предложение не было сплошным набором слов. content content content content -content или вашего друга?А то по вашей манере написания это непонятно.content.[/color[color=#FF0000][color=#FF0000][color=#FFFF80][/color]"##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)