package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^Give me \d+ of (\S+)`)
var str = `Give me 4 of ABCD_X and then do something`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}