$re = '/^Give me \d+ of (\S+)/m';
$str = 'Give me 4 of ABCD_X and then do something';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);